最近在写一个项目,需要进行大量的json解析,所以对解析速度要求很高。目前,使用最多的是精易模块、E2EE、zyjson中的json解析功能,就简单测试了下三者哪个速度最快。
测试文本:点我下载(544KB)
测试结果:E2EE > 精易模块 >zyjson

.版本 2
.支持库 e2ee
.支持库 EThread

.程序集 窗口程序集_启动窗口
.程序集变量 文本, 文本型

.子程序 _按钮1_被单击

文本 = 读入文本文件 (“C:\Users\Administrator\Desktop\111.txt”, )
启动线程 (&子程序zyjson, , )
程序_延时 (1000)
启动线程 (&子程序e2ee, , )
程序_延时 (1000)
启动线程 (&子程序jingyi, , )
程序_延时 (1000)

.子程序 子程序zyjson
.局部变量 json, zyJsonValue
.局部变量 time, 整数型

time = 取启动时间 ()
json.解析 (文本)
json.取文本 (“data.data.sport.1.name”)
取文本左边 (json.到文本 (“data.data.sport.1.region.2480001.competition.3068.game.13981557.market.264532528”, 真), 10)
编辑框1.加入文本 (#换行符 + “zyjson:”, 到文本 (取启动时间 () - time))

.子程序 子程序e2ee
.局部变量 局_键值, 存取键值表
.局部变量 time, 整数型

time = 取启动时间 ()
局_键值.从JSON载入 (文本, 真, 真)
局_键值.取文本 (“//data.data.sport.1.name”)
取文本左边 (局_键值.取文本 (“//data.data.sport.1.region.420001.competition.1805.game.13940295.market.264564592”), 10)
编辑框1.加入文本 (#换行符 + “e2ee:”, 到文本 (取启动时间 () - time))

.子程序 子程序jingyi
.局部变量 time, 整数型
.局部变量 json, 类_json

time = 取启动时间 ()
json.解析 (文本)
json.取通用属性 (“data.data.sport['1'].name”)
取文本左边 (json.取通用属性 (“data.data.sport['1'].region['420001'].competition['1805'].game['13940295'].market['264564592']”, 真), 10)
编辑框1.加入文本 (#换行符 + “jingyi:”, 到文本 (取启动时间 () - time))
易语言